Quick and Easy Oracle Database 19c Build – A Git deployment

Here’s a quick and easy (not dirty) why to get Oracle Database 19c up and running.  Its based on a github repository.

Once you run the oracle_19c_install command, you will essentially have the following built out:

  1. All required Linux rpms installed and parameters set
  2. A 19c Oracle DB Home installed
  3. A 19c DB created with a single
  4. CDB will be opened and PDB started in left in OPEN MODE

Warning this is essentially my output listing…. hope its easy to follow along:

First ya need to have git installed, if you dont have it already

[root@git19c ~]# yum -y install git

Loaded plugins: langpacks, ulninfo

Resolving Dependencies

--> Running transaction check

---> Package git.x86_64 0:1.8.3.1-20.el7 will be installed

--> Processing Dependency: perl-Git = 1.8.3.1-20.el7 for package: git-1.8.3.1-20.el7.x86_64

--> Processing Dependency: perl(Term::ReadKey) for package: git-1.8.3.1-20.el7.x86_64

--> Processing Dependency: perl(Git) for package: git-1.8.3.1-20.el7.x86_64

--> Processing Dependency: perl(Error) for package: git-1.8.3.1-20.el7.x86_64

--> Running transaction check

---> Package perl-Error.noarch 1:0.17020-2.el7 will be installed

---> Package perl-Git.noarch 0:1.8.3.1-20.el7 will be installed

---> Package perl-TermReadKey.x86_64 0:2.30-20.el7 will be installed

--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================================
Package                                       Arch                                Version                                      Repository                               Size
==============================================================================================================================================================================

Installing:

git                                           x86_64                              1.8.3.1-20.el7                               ol7_latest                              4.4 M

Installing for dependencies:

perl-Error                                    noarch                              1:0.17020-2.el7                              ol7_latest                               31 k

perl-Git                                      noarch                              1.8.3.1-20.el7                               ol7_latest                               55 k

perl-TermReadKey                              x86_64                              2.30-20.el7                                  ol7_latest                               30 k

Transaction Summary

=========================================================================================================================================================

Install  1 Package (+3 Dependent packages)

Total download size: 4.5 M

Installed size: 22 M

Downloading packages:

(1/4): perl-Error-0.17020-2.el7.noarch.rpm                                                                                                             |  31 kB  00:00:00     

(2/4): perl-Git-1.8.3.1-20.el7.noarch.rpm                                                                                                              |  55 kB  00:00:00     

(3/4): perl-TermReadKey-2.30-20.el7.x86_64.rpm                                                                                                         |  30 kB  00:00:00     

(4/4): git-1.8.3.1-20.el7.x86_64.rpm                                                                                                                   | 4.4 MB  00:00:00     

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Total                                                                                                                                         7.5 MB/s | 4.5 MB  00:00:00     

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

  Installing : 1:perl-Error-0.17020-2.el7.noarch                                                                                                                          1/4

  Installing : perl-TermReadKey-2.30-20.el7.x86_64                                                                                                                        2/4

  Installing : git-1.8.3.1-20.el7.x86_64                                                                                                                                  3/4

  Installing : perl-Git-1.8.3.1-20.el7.noarch                                                                                                                             4/4

  Verifying  : perl-Git-1.8.3.1-20.el7.noarch                                                                                                                             1/4

  Verifying  : 1:perl-Error-0.17020-2.el7.noarch                                                                                                                          2/4

  Verifying  : git-1.8.3.1-20.el7.x86_64                                                                                                                                  3/4

  Verifying  : perl-TermReadKey-2.30-20.el7.x86_64                                                                                                                        4/4

Installed:

  git.x86_64 0:1.8.3.1-20.el7                                                                                                                                                 

Dependency Installed:

  perl-Error.noarch 1:0.17020-2.el7                       perl-Git.noarch 0:1.8.3.1-20.el7                       perl-TermReadKey.x86_64 0:2.30-20.el7                      

Complete!

[root@git19c ~]# git version

git version 1.8.3.1


Now lets get the database bits from git 
[root@git19c ~]# git clone https://github.com/dockerhelp/docker-oracle-ee-19c.git

Cloning into 'docker-oracle-ee-19c'...

remote: Enumerating objects: 12, done.

remote: Counting objects: 100% (12/12), done.

remote: Compressing objects: 100% (11/11), done.

remote: Total 12 (delta 0), reused 0 (delta 0), pack-reused 0

Unpacking objects: 100% (12/12), done.

[root@git19c ~]# ls -lrt .
total 0
drwxr-xr-x. 4 root root 68 Oct  6 22:57 docker-oracle-ee-19c

./docker-oracle-ee-19c:

drwxr-xr-x. 2 root root 4096 Oct  6 22:57 install

-rw-r--r--. 1 root root  412 Oct  6 22:57 Dockerfile

-rw-r--r--. 1 root root   23 Oct  6 22:57 README.md

./docker-oracle-ee-19c/install:

total 2240

-rw-r--r--. 1 root root     627 Oct  6 22:57 oracle-19c-ee.rsp

-rw-r--r--. 1 root root    3549 Oct  6 22:57 oracle_19c_install.sh

-rw-r--r--. 1 root root    1201 Oct  6 22:57 post_install.sh

-rw-r--r--. 1 root root     495 Oct  6 22:57 tns.sh

-rw-r--r--. 1 root root 2267480 Oct  6 22:57 gosu

-rw-r--r--. 1 root root     441 Oct  6 22:57 netca.rsp

-rw-r--r--. 1 root root     486 Oct  6 22:57 dbca_19c.rsp

Review the oracle_19c_install.sh file and make appropriate changes to reflect your 
environment that you want to build; eg, OHome location and DBname, etc..
[root@git19c install]# more oracle_19c_install.sh

#!/bin/bash

set -e

export INSTALL=$HOME/docker-oracle-ee-19c/install

echo `hostname -I|awk '{print $1}'` `hostname -s` `hostname` >> /etc/hosts

echo "Installing Dependencies"

yum install -y wget unzip binutils.x86_64 compat-libcap1.x86_64 gcc.x86_64 gcc-c++.x86_64 glibc.i686 glibc.x86_64 \

glibc-devel.i686 glibc-devel.x86_64 ksh compat-libstdc++-33 libaio.i686 libaio.x86_64 libaio-devel.i686 libaio-devel.x86_64 \

libgcc.i686 libgcc.x86_64 libstdc++.i686 libstdc++.x86_64 libstdc++-devel.i686 libstdc++-devel.x86_64 libXi.i686 libXi.x86_64 \

libXtst.i686 libXtst.x86_64 make.x86_64 sysstat.x86_64 oracle-database-preinstall-19c && yum clean all

rm -rf /var/cache/yum

echo "Creating Directory"

rm -rf /u01

mkdir -p /u01 && mkdir -p /u01/app/oracle/product/19.0.0/dbhome_1 && chown -R oracle:oinstall /u01 && chmod -R 775 /u01

touch /etc/oratab

chmod 777 /etc/oratab

chmod 755 $INSTALL/post_install.sh

echo "Setting ENV"

echo oracle:oracle | chpasswd

export ORACLE_BASE=/u01/app/oracle

export ORACLE_HOME=/u01/app/oracle/product/19.0.0/dbhome_1

export ORACLE_SID=ORCL19 >> /home/oracle/.bash_profile

export ORACLE_HOME=/u01/app/oracle/product/19.0.0/dbhome_1 >> /home/oracle/.bash_profile

export PATH=$ORACLE_HOME/bin:$PATH >> /home/oracle/.bash_profile

#Download oracle database zip

echo "Downloading oracle database zip"

wget -q --load-cookies /tmp/cookies.txt "https://docs.google.com/uc?export=download&confirm=$(wget --quiet --save-cookies /tmp/cookies.txt --keep-session-cookies --no-check-c

ertificate 'https://docs.google.com/uc?export=download&id=1QinowHmGgiOCdj-OO20qaTQGHfYN2u6M' -O- | sed -rn 's/.*confirm=([0-9A-Za-z_]+).*/\1\n/p')&id=1QinowHmGgiOCdj-OO20qaTQ

[root@git19c install]#  chmod u+x $HOME/docker-oracle-ee-19c/install/oracle_19c_install.sh

[root@git19c install]# sh oracle_19c_install.sh

Installing Dependencies

Loaded plugins: langpacks, ulninfo

ol7_UEKR5                                                                                                                                              | 2.8 kB  00:00:00     

ol7_addons                                                                                                                                             | 2.8 kB  00:00:00     

ol7_developer                                                                                                                                          | 2.8 kB  00:00:00     

ol7_developer_EPEL                                                                                                                                     | 3.4 kB  00:00:00     

ol7_ksplice                                                                                                                                            | 2.8 kB  00:00:00     

ol7_latest                                                                                                                                             | 3.4 kB  00:00:00     

ol7_oci_included                                                                                                                                       | 2.9 kB  00:00:00     

ol7_optional_latest                                                                                                                                    | 2.8 kB  00:00:00     

ol7_software_collections                                                                                                                               | 2.8 kB  00:00:00     

(1/19): ol7_addons/x86_64/updateinfo                                                                                                                   |  69 kB  00:00:00     

(2/19): ol7_UEKR5/x86_64/updateinfo                                                                                                                    |  13 kB  00:00:00     

(3/19): ol7_developer_EPEL/x86_64/group_gz                                                                                                             |  87 kB  00:00:00     

(4/19): ol7_developer/x86_64/primary_db                                                                                                                | 434 kB  00:00:00     

(5/19): ol7_addons/x86_64/primary_db                                                                                                                   | 129 kB  00:00:00     

(6/19): ol7_developer_EPEL/x86_64/updateinfo                                                                                                           | 4.9 kB  00:00:00     

(7/19): ol7_ksplice/primary_db                                                                                                                         | 187 kB  00:00:00     

(8/19): ol7_UEKR5/x86_64/primary_db                                                                                                                    | 2.5 MB  00:00:00     

(9/19): ol7_latest/x86_64/group_gz                                                                                                                     | 148 kB  00:00:00     

(10/19): ol7_developer/x86_64/updateinfo                                                                                                               |   71 B  00:00:00     

(11/19): ol7_latest/x86_64/updateinfo                                                                                                                  | 2.6 MB  00:00:00     

(12/19): ol7_developer_EPEL/x86_64/primary_db                                                                                                          |  11 MB  00:00:00     

(13/19): ol7_optional_latest/x86_64/updateinfo                                                                                                         | 853 kB  00:00:00     

(14/19): ol7_ksplice/updateinfo                                                                                                                        | 4.8 kB  00:00:00     

(15/19): ol7_oci_included/x86_64/primary_db                                                                                                            |  48 kB  00:00:00     

(16/19): ol7_latest/x86_64/primary_db                                                                                                                  |  15 MB  00:00:00     

(17/19): ol7_software_collections/x86_64/updateinfo                                                                                                    | 8.7 kB  00:00:00     

(18/19): ol7_optional_latest/x86_64/primary_db                                                                                                         | 4.0 MB  00:00:00     

(19/19): ol7_software_collections/x86_64/primary_db                                                                                                    | 4.7 MB  00:00:00     

Package wget-1.14-18.el7_6.1.x86_64 already installed and latest version

Package unzip-6.0-20.el7.x86_64 already installed and latest version

Package binutils-2.27-41.base.0.1.el7.x86_64 already installed and latest version

Package glibc-2.17-292.0.1.el7.x86_64 already installed and latest version

Package libaio-0.3.109-13.el7.x86_64 already installed and latest version

Package libgcc-4.8.5-39.0.1.el7.x86_64 already installed and latest version

Package libstdc++-4.8.5-39.0.1.el7.x86_64 already installed and latest version

Package 1:make-3.82-24.el7.x86_64 already installed and latest version

Package sysstat-10.1.5-18.el7.x86_64 already installed and latest version

Resolving Dependencies

--> Running transaction check

---> Package compat-libcap1.x86_64 0:1.10-7.el7 will be installed

---> Package compat-libstdc++-33.x86_64 0:3.2.3-72.el7 will be installed

---> Package gcc.x86_64 0:4.8.5-39.0.1.el7 will be installed

--> Processing Dependency: cpp = 4.8.5-39.0.1.el7 for package: gcc-4.8.5-39.0.1.el7.x86_64

--> Processing Dependency: libmpfr.so.4()(64bit) for package: gcc-4.8.5-39.0.1.el7.x86_64

--> Processing Dependency: libmpc.so.3()(64bit) for package: gcc-4.8.5-39.0.1.el7.x86_64

---> Package gcc-c++.x86_64 0:4.8.5-39.0.1.el7 will be installed

---> Package glibc.i686 0:2.17-292.0.1.el7 will be installed

--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-292.0.1.el7.i686

--> Processing Dependency: libfreebl3.so for package: glibc-2.17-292.0.1.el7.i686

---> Package glibc-devel.i686 0:2.17-292.0.1.el7 will be installed

--> Processing Dependency: glibc-headers = 2.17-292.0.1.el7 for package: glibc-devel-2.17-292.0.1.el7.i686

--> Processing Dependency: glibc-headers for package: glibc-devel-2.17-292.0.1.el7.i686

---> Package glibc-devel.x86_64 0:2.17-292.0.1.el7 will be installed

---> Package ksh.x86_64 0:20120801-139.0.1.el7 will be installed

---> Package libXi.i686 0:1.7.9-1.el7 will be installed

--> Processing Dependency: libX11 >= 1.5.99.902 for package: libXi-1.7.9-1.el7.i686

--> Processing Dependency: libXext.so.6 for package: libXi-1.7.9-1.el7.i686

--> Processing Dependency: libX11.so.6 for package: libXi-1.7.9-1.el7.i686

---> Package libXi.x86_64 0:1.7.9-1.el7 will be installed

--> Processing Dependency: libXext.so.6()(64bit) for package: libXi-1.7.9-1.el7.x86_64

---> Package libXtst.i686 0:1.2.3-1.el7 will be installed

---> Package libXtst.x86_64 0:1.2.3-1.el7 will be installed

---> Package libaio.i686 0:0.3.109-13.el7 will be installed

---> Package libaio-devel.i686 0:0.3.109-13.el7 will be installed

---> Package libaio-devel.x86_64 0:0.3.109-13.el7 will be installed

---> Package libgcc.i686 0:4.8.5-39.0.1.el7 will be installed

---> Package libstdc++.i686 0:4.8.5-39.0.1.el7 will be installed

---> Package libstdc++-devel.i686 0:4.8.5-39.0.1.el7 will be installed

---> Package libstdc++-devel.x86_64 0:4.8.5-39.0.1.el7 will be installed

---> Package oracle-database-preinstall-19c.x86_64 0:1.0-1.el7 will be installed

--> Processing Dependency: xorg-x11-xauth for package: oracle-database-preinstall-19c-1.0-1.el7.x86_64

--> Processing Dependency: xorg-x11-utils for package: oracle-database-preinstall-19c-1.0-1.el7.x86_64

--> Processing Dependency: psmisc for package: oracle-database-preinstall-19c-1.0-1.el7.x86_64

--> Running transaction check

---> Package cpp.x86_64 0:4.8.5-39.0.1.el7 will be installed

---> Package glibc-headers.x86_64 0:2.17-292.0.1.el7 will be installed

--> Processing Dependency: kernel-headers >= 2.2.1 for package: glibc-headers-2.17-292.0.1.el7.x86_64

--> Processing Dependency: kernel-headers for package: glibc-headers-2.17-292.0.1.el7.x86_64

---> Package libX11.i686 0:1.6.7-2.el7 will be installed

--> Processing Dependency: libX11-common >= 1.6.7-2.el7 for package: libX11-1.6.7-2.el7.i686

--> Processing Dependency: libxcb.so.1 for package: libX11-1.6.7-2.el7.i686

---> Package libX11.x86_64 0:1.6.7-2.el7 will be installed

--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.6.7-2.el7.x86_64

---> Package libXext.i686 0:1.3.3-3.el7 will be installed

---> Package libXext.x86_64 0:1.3.3-3.el7 will be installed

---> Package libmpc.x86_64 0:1.0.1-3.el7 will be installed

---> Package mpfr.x86_64 0:3.1.1-4.el7 will be installed

---> Package nss-softokn-freebl.i686 0:3.44.0-5.0.1.el7 will be installed

---> Package psmisc.x86_64 0:22.20-16.el7 will be installed

---> Package xorg-x11-utils.x86_64 0:7.5-23.el7 will be installed

--> Processing Dependency: libdmx.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXxf86vm.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXxf86misc.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXxf86dga.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXv.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXrender.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXrandr.so.2()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

--> Processing Dependency: libXinerama.so.1()(64bit) for package: xorg-x11-utils-7.5-23.el7.x86_64

---> Package xorg-x11-xauth.x86_64 1:1.0.9-1.el7 will be installed

--> Processing Dependency: libXmuu.so.1()(64bit) for package: 1:xorg-x11-xauth-1.0.9-1.el7.x86_64

--> Processing Dependency: libXau.so.6()(64bit) for package: 1:xorg-x11-xauth-1.0.9-1.el7.x86_64

--> Running transaction check

---> Package kernel-headers.x86_64 0:3.10.0-1062.1.2.el7 will be installed

---> Package libX11-common.noarch 0:1.6.7-2.el7 will be installed

---> Package libXau.x86_64 0:1.0.8-2.1.el7 will be installed

---> Package libXinerama.x86_64 0:1.1.3-2.1.el7 will be installed

---> Package libXmu.x86_64 0:1.1.2-2.el7 will be installed

--> Processing Dependency: libXt.so.6()(64bit) for package: libXmu-1.1.2-2.el7.x86_64

---> Package libXrandr.x86_64 0:1.5.1-2.el7 will be installed

---> Package libXrender.x86_64 0:0.9.10-1.el7 will be installed

---> Package libXv.x86_64 0:1.0.11-1.el7 will be installed

---> Package libXxf86dga.x86_64 0:1.1.4-2.1.el7 will be installed

---> Package libXxf86misc.x86_64 0:1.0.3-7.1.el7 will be installed

---> Package libXxf86vm.x86_64 0:1.1.4-1.el7 will be installed

---> Package libdmx.x86_64 0:1.1.3-3.el7 will be installed

---> Package libxcb.i686 0:1.13-1.el7 will be installed

--> Processing Dependency: libXau.so.6 for package: libxcb-1.13-1.el7.i686

---> Package libxcb.x86_64 0:1.13-1.el7 will be installed

--> Running transaction check

---> Package libXau.i686 0:1.0.8-2.1.el7 will be installed

---> Package libXt.x86_64 0:1.1.5-3.el7 will be installed

--> Processing Dependency: libSM.so.6()(64bit) for package: libXt-1.1.5-3.el7.x86_64

--> Processing Dependency: libICE.so.6()(64bit) for package: libXt-1.1.5-3.el7.x86_64

--> Running transaction check

---> Package libICE.x86_64 0:1.0.9-9.el7 will be installed

---> Package libSM.x86_64 0:1.2.2-2.el7 will be installed

--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================================
Package                                                Arch                           Version                                       Repository                          Size
=========================================================================================================================================================
Installing:
compat-libcap1                                         x86_64                         1.10-7.el7                                    ol7_latest                          17 k
compat-libstdc++-33                                    x86_64                         3.2.3-72.el7                                  ol7_latest                         190 k
gcc                                                    x86_64                         4.8.5-39.0.1.el7                              ol7_latest                          16 M
gcc-c++                                                x86_64                         4.8.5-39.0.1.el7                              ol7_latest                         7.2 M
glibc                                                  i686                           2.17-292.0.1.el7                              ol7_latest                         4.3 M
glibc-devel                                            i686                           2.17-292.0.1.el7                              ol7_latest                         1.1 M
glibc-devel                                            x86_64                         2.17-292.0.1.el7                              ol7_latest                         1.1 M
ksh                                                    x86_64                         20120801-139.0.1.el7                          ol7_latest                         883 k
libXi                                                  i686                           1.7.9-1.el7                                   ol7_latest                          40 k
libXi                                                  x86_64                         1.7.9-1.el7                                   ol7_latest                          40 k
libXtst                                                i686                           1.2.3-1.el7                                   ol7_latest                          20 k
libXtst                                                x86_64                         1.2.3-1.el7                                   ol7_latest                          20 k
libaio                                                 i686                           0.3.109-13.el7                                ol7_latest                          24 k
libaio-devel                                           i686                           0.3.109-13.el7                                ol7_latest                          12 k
libaio-devel                                           x86_64                         0.3.109-13.el7                                ol7_latest                          12 k
libgcc                                                 i686                           4.8.5-39.0.1.el7                              ol7_latest                         110 k
libstdc++                                              i686                           4.8.5-39.0.1.el7                              ol7_latest                         318 k
libstdc++-devel                                        i686                           4.8.5-39.0.1.el7                              ol7_latest                         1.5 M
libstdc++-devel                                        x86_64                         4.8.5-39.0.1.el7                              ol7_latest                         1.5 M

oracle-database-preinstall-19c                         x86_64                         1.0-1.el7                                     ol7_latest                          18 k

Installing for dependencies:

cpp                                                    x86_64                         4.8.5-39.0.1.el7                              ol7_latest                         6.0 M

glibc-headers                                          x86_64                         2.17-292.0.1.el7                              ol7_latest                         689 k

kernel-headers                                         x86_64                         3.10.0-1062.1.2.el7                           ol7_latest                         8.7 M

libICE                                                 x86_64                         1.0.9-9.el7                                   ol7_latest                          66 k

libSM                                                  x86_64                         1.2.2-2.el7                                   ol7_latest                          39 k

libX11                                                 i686                           1.6.7-2.el7                                   ol7_latest                         610 k

libX11                                                 x86_64                         1.6.7-2.el7                                   ol7_latest                         606 k

libX11-common                                          noarch                         1.6.7-2.el7                                   ol7_latest                         164 k

libXau                                                 i686                           1.0.8-2.1.el7                                 ol7_latest                          28 k

libXau                                                 x86_64                         1.0.8-2.1.el7                                 ol7_latest                          28 k

libXext                                                i686                           1.3.3-3.el7                                   ol7_latest                          38 k

libXext                                                x86_64                         1.3.3-3.el7                                   ol7_latest                          38 k

libXinerama                                            x86_64                         1.1.3-2.1.el7                                 ol7_latest                          13 k

libXmu                                                 x86_64                         1.1.2-2.el7                                   ol7_latest                          70 k

libXrandr                                              x86_64                         1.5.1-2.el7                                   ol7_latest                          27 k

libXrender                                             x86_64                         0.9.10-1.el7                                  ol7_latest                          25 k

libXt                                                  x86_64                         1.1.5-3.el7                                   ol7_latest                         172 k

libXv                                                  x86_64                         1.0.11-1.el7                                  ol7_latest                          18 k

libXxf86dga                                            x86_64                         1.1.4-2.1.el7                                 ol7_latest                          18 k

libXxf86misc                                           x86_64                         1.0.3-7.1.el7                                 ol7_latest                          19 k

libXxf86vm                                             x86_64                         1.1.4-1.el7                                   ol7_latest                          17 k

libdmx                                                 x86_64                         1.1.3-3.el7                                   ol7_latest                          15 k

libmpc                                                 x86_64                         1.0.1-3.el7                                   ol7_latest                          49 k

libxcb                                                 i686                           1.13-1.el7                                    ol7_latest                         229 k

libxcb                                                 x86_64                         1.13-1.el7                                    ol7_latest                         213 k

mpfr                                                   x86_64                         3.1.1-4.el7                                   ol7_latest                         198 k

nss-softokn-freebl                                     i686                           3.44.0-5.0.1.el7                              ol7_latest                         214 k

psmisc                                                 x86_64                         22.20-16.el7                                  ol7_latest                         141 k

xorg-x11-utils                                         x86_64                         7.5-23.el7                                    ol7_latest                         114 k

xorg-x11-xauth                                         x86_64                         1:1.0.9-1.el7                                 ol7_latest                          29 k

Transaction Summary

=========================================================================================================================================================
Install  20 Packages (+30 Dependent packages)
Total download size: 53 M

Installed size: 121 M

Downloading packages:

(1/50): compat-libcap1-1.10-7.el7.x86_64.rpm                                                                                                           |  17 kB  00:00:00     

(2/50): compat-libstdc++-33-3.2.3-72.el7.x86_64.rpm                                                                                                    | 190 kB  00:00:00     

(3/50): cpp-4.8.5-39.0.1.el7.x86_64.rpm                                                                                                                | 6.0 MB  00:00:00     

(4/50): gcc-c++-4.8.5-39.0.1.el7.x86_64.rpm                                                                                                            | 7.2 MB  00:00:00     

(5/50): gcc-4.8.5-39.0.1.el7.x86_64.rpm                                                                                                                |  16 MB  00:00:00     

(6/50): glibc-2.17-292.0.1.el7.i686.rpm                                                                                                                | 4.3 MB  00:00:00     

(7/50): glibc-devel-2.17-292.0.1.el7.i686.rpm                                                                                                          | 1.1 MB  00:00:00     

(8/50): glibc-devel-2.17-292.0.1.el7.x86_64.rpm                                                                                                        | 1.1 MB  00:00:00     

(9/50): glibc-headers-2.17-292.0.1.el7.x86_64.rpm                                                                                                      | 689 kB  00:00:00     

(10/50): ksh-20120801-139.0.1.el7.x86_64.rpm                                                                                                           | 883 kB  00:00:00     

(11/50): libICE-1.0.9-9.el7.x86_64.rpm                                                                                                                 |  66 kB  00:00:00     

(12/50): libSM-1.2.2-2.el7.x86_64.rpm                                                                                                                  |  39 kB  00:00:00     

(13/50): libX11-1.6.7-2.el7.i686.rpm                                                                                                                   | 610 kB  00:00:00     

(14/50): libX11-1.6.7-2.el7.x86_64.rpm                                                                                                                 | 606 kB  00:00:00     

(15/50): libX11-common-1.6.7-2.el7.noarch.rpm                                                                                                          | 164 kB  00:00:00     

(16/50): libXau-1.0.8-2.1.el7.i686.rpm                                                                                                                 |  28 kB  00:00:00     

(17/50): libXau-1.0.8-2.1.el7.x86_64.rpm                                                                                                               |  28 kB  00:00:00     

(18/50): kernel-headers-3.10.0-1062.1.2.el7.x86_64.rpm                                                                                                 | 8.7 MB  00:00:00     

(19/50): libXext-1.3.3-3.el7.i686.rpm                                                                                                                  |  38 kB  00:00:00     

(20/50): libXext-1.3.3-3.el7.x86_64.rpm                                                                                                                |  38 kB  00:00:00     

(21/50): libXi-1.7.9-1.el7.i686.rpm                                                                                                                    |  40 kB  00:00:00     

(22/50): libXi-1.7.9-1.el7.x86_64.rpm                                                                                                                  |  40 kB  00:00:00     

(23/50): libXinerama-1.1.3-2.1.el7.x86_64.rpm                                                                                                          |  13 kB  00:00:00     

(24/50): libXmu-1.1.2-2.el7.x86_64.rpm                                                                                                                 |  70 kB  00:00:00     

(25/50): libXrandr-1.5.1-2.el7.x86_64.rpm                                                                                                              |  27 kB  00:00:00     

(26/50): libXrender-0.9.10-1.el7.x86_64.rpm                                                                                                            |  25 kB  00:00:00     

(27/50): libXt-1.1.5-3.el7.x86_64.rpm                                                                                                                  | 172 kB  00:00:00     

(28/50): libXtst-1.2.3-1.el7.i686.rpm                                                                                                                  |  20 kB  00:00:00     

(29/50): libXtst-1.2.3-1.el7.x86_64.rpm                                                                                                                |  20 kB  00:00:00     

(30/50): libXv-1.0.11-1.el7.x86_64.rpm                                                                                                                 |  18 kB  00:00:00     

(31/50): libXxf86dga-1.1.4-2.1.el7.x86_64.rpm                                                                                                          |  18 kB  00:00:00     

(32/50): libXxf86misc-1.0.3-7.1.el7.x86_64.rpm                                                                                                         |  19 kB  00:00:00     

(33/50): libXxf86vm-1.1.4-1.el7.x86_64.rpm                                                                                                             |  17 kB  00:00:00     

(34/50): libaio-0.3.109-13.el7.i686.rpm                                                                                                                |  24 kB  00:00:00     

(35/50): libaio-devel-0.3.109-13.el7.i686.rpm                                                                                                          |  12 kB  00:00:00     

(36/50): libaio-devel-0.3.109-13.el7.x86_64.rpm                                                                                                        |  12 kB  00:00:00     

(37/50): libdmx-1.1.3-3.el7.x86_64.rpm                                                                                                                 |  15 kB  00:00:00     

(38/50): libgcc-4.8.5-39.0.1.el7.i686.rpm                                                                                                              | 110 kB  00:00:00     

(39/50): libmpc-1.0.1-3.el7.x86_64.rpm                                                                                                                 |  49 kB  00:00:00     

(40/50): libstdc++-4.8.5-39.0.1.el7.i686.rpm                                                                                                           | 318 kB  00:00:00     

(41/50): libstdc++-devel-4.8.5-39.0.1.el7.i686.rpm                                                                                                     | 1.5 MB  00:00:00     

(42/50): libstdc++-devel-4.8.5-39.0.1.el7.x86_64.rpm                                                                                                   | 1.5 MB  00:00:00     

(43/50): libxcb-1.13-1.el7.i686.rpm                                                                                                                    | 229 kB  00:00:00     

(44/50): libxcb-1.13-1.el7.x86_64.rpm                                                                                                                  | 213 kB  00:00:00     

(45/50): mpfr-3.1.1-4.el7.x86_64.rpm                                                                                                                   | 198 kB  00:00:00     

(46/50): nss-softokn-freebl-3.44.0-5.0.1.el7.i686.rpm                                                                                                  | 214 kB  00:00:00     

(47/50): oracle-database-preinstall-19c-1.0-1.el7.x86_64.rpm                                                                                           |  18 kB  00:00:00     

(48/50): psmisc-22.20-16.el7.x86_64.rpm                                                                                                                | 141 kB  00:00:00     

(49/50): xorg-x11-utils-7.5-23.el7.x86_64.rpm                                                                                                          | 114 kB  00:00:00     

(50/50): xorg-x11-xauth-1.0.9-1.el7.x86_64.rpm                                                                                                         |  29 kB  00:00:00     

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Total                                                                                                                                         133 MB/s |  53 MB  00:00:00     

Running transaction check

Running transaction test

Transaction test succeeded

Running transaction

  Installing : libX11-common-1.6.7-2.el7.noarch                                                                                                                          1/50

  Installing : kernel-headers-3.10.0-1062.1.2.el7.x86_64                                                                                                                 2/50

  Installing : libaio-devel-0.3.109-13.el7.x86_64                                                                                                                        3/50

  Installing : libstdc++-devel-4.8.5-39.0.1.el7.x86_64                                                                                                                   4/50

  Installing : libgcc-4.8.5-39.0.1.el7.i686                                                                                                                              5/50

  Installing : glibc-2.17-292.0.1.el7.i686                                                                                                                               6/50

  Installing : nss-softokn-freebl-3.44.0-5.0.1.el7.i686                                                                                                                  7/50

  Installing : mpfr-3.1.1-4.el7.x86_64                                                                                                                                   8/50

  Installing : libmpc-1.0.1-3.el7.x86_64                                                                                                                                 9/50

  Installing : libICE-1.0.9-9.el7.x86_64                                                                                                                                10/50

  Installing : glibc-headers-2.17-292.0.1.el7.x86_64                                                                                                                    11/50

  Installing : glibc-devel-2.17-292.0.1.el7.x86_64                                                                                                                      12/50

  Installing : libXau-1.0.8-2.1.el7.x86_64                                                                                                                              13/50

  Installing : libxcb-1.13-1.el7.x86_64                                                                                                                                 14/50

  Installing : libX11-1.6.7-2.el7.x86_64                                                                                                                                15/50

  Installing : libXext-1.3.3-3.el7.x86_64                                                                                                                               16/50

  Installing : libXi-1.7.9-1.el7.x86_64                                                                                                                                 17/50

  Installing : libXrender-0.9.10-1.el7.x86_64                                                                                                                           18/50

  Installing : libXrandr-1.5.1-2.el7.x86_64                                                                                                                             19/50

  Installing : libXtst-1.2.3-1.el7.x86_64                                                                                                                               20/50

  Installing : libdmx-1.1.3-3.el7.x86_64                                                                                                                                21/50

  Installing : libXinerama-1.1.3-2.1.el7.x86_64                                                                                                                         22/50

  Installing : libXv-1.0.11-1.el7.x86_64                                                                                                                                23/50

  Installing : libXxf86vm-1.1.4-1.el7.x86_64                                                                                                                            24/50

  Installing : libXxf86misc-1.0.3-7.1.el7.x86_64                                                                                                                        25/50

  Installing : libXxf86dga-1.1.4-2.1.el7.x86_64                                                                                                                         26/50

  Installing : xorg-x11-utils-7.5-23.el7.x86_64                                                                                                                         27/50

  Installing : libSM-1.2.2-2.el7.x86_64                                                                                                                                 28/50

  Installing : libXt-1.1.5-3.el7.x86_64                                                                                                                                 29/50

  Installing : libXmu-1.1.2-2.el7.x86_64                                                                                                                                30/50

  Installing : 1:xorg-x11-xauth-1.0.9-1.el7.x86_64                                                                                                                      31/50

  Installing : cpp-4.8.5-39.0.1.el7.x86_64                                                                                                                              32/50

  Installing : gcc-4.8.5-39.0.1.el7.x86_64                                                                                                                              33/50

  Installing : psmisc-22.20-16.el7.x86_64                                                                                                                               34/50

  Installing : compat-libcap1-1.10-7.el7.x86_64                                                                                                                         35/50

  Installing : ksh-20120801-139.0.1.el7.x86_64                                                                                                                          36/50

  Installing : compat-libstdc++-33-3.2.3-72.el7.x86_64                                                                                                                  37/50

  Installing : libstdc++-4.8.5-39.0.1.el7.i686                                                                                                                          38/50

  Installing : libstdc++-devel-4.8.5-39.0.1.el7.i686                                                                                                                    39/50

  Installing : libaio-0.3.109-13.el7.i686                                                                                                                               40/50

  Installing : libaio-devel-0.3.109-13.el7.i686                                                                                                                         41/50

  Installing : libXau-1.0.8-2.1.el7.i686                                                                                                                                42/50

  Installing : oracle-database-preinstall-19c-1.0-1.el7.x86_64                                                                                                          43/50

  Installing : gcc-c++-4.8.5-39.0.1.el7.x86_64                                                                                                                          44/50

  Installing : glibc-devel-2.17-292.0.1.el7.i686                                                                                                                        45/50

  Installing : libxcb-1.13-1.el7.i686                                                                                                                                   46/50

  Installing : libX11-1.6.7-2.el7.i686                                                                                                                                  47/50

  Installing : libXext-1.3.3-3.el7.i686                                                                                                                                 48/50

  Installing : libXi-1.7.9-1.el7.i686                                                                                                                                   49/50

  Installing : libXtst-1.2.3-1.el7.i686                                                                                                                                 50/50

  Verifying  : libXext-1.3.3-3.el7.x86_64                                                                                                                                1/50

  Verifying  : libXi-1.7.9-1.el7.x86_64                                                                                                                                  2/50

  Verifying  : libdmx-1.1.3-3.el7.x86_64                                                                                                                                 3/50

  Verifying  : libICE-1.0.9-9.el7.x86_64                                                                                                                                 4/50

  Verifying  : libaio-devel-0.3.109-13.el7.i686                                                                                                                          5/50

  Verifying  : libXinerama-1.1.3-2.1.el7.x86_64                                                                                                                          6/50

  Verifying  : libXrender-0.9.10-1.el7.x86_64                                                                                                                            7/50

  Verifying  : libXv-1.0.11-1.el7.x86_64                                                                                                                                 8/50

  Verifying  : libXext-1.3.3-3.el7.i686                                                                                                                                  9/50

  Verifying  : cpp-4.8.5-39.0.1.el7.x86_64                                                                                                                              10/50

  Verifying  : libXxf86vm-1.1.4-1.el7.x86_64                                                                                                                            11/50

  Verifying  : libXt-1.1.5-3.el7.x86_64                                                                                                                                 12/50

  Verifying  : libstdc++-devel-4.8.5-39.0.1.el7.i686                                                                                                                    13/50

  Verifying  : libxcb-1.13-1.el7.i686                                                                                                                                   14/50

  Verifying  : libstdc++-devel-4.8.5-39.0.1.el7.x86_64                                                                                                                  15/50

  Verifying  : libXi-1.7.9-1.el7.i686                                                                                                                                   16/50

  Verifying  : glibc-devel-2.17-292.0.1.el7.x86_64                                                                                                                      17/50

  Verifying  : xorg-x11-utils-7.5-23.el7.x86_64                                                                                                                         18/50

  Verifying  : libXau-1.0.8-2.1.el7.i686                                                                                                                                19/50

  Verifying  : libXtst-1.2.3-1.el7.x86_64                                                                                                                               20/50

  Verifying  : oracle-database-preinstall-19c-1.0-1.el7.x86_64                                                                                                          21/50

  Verifying  : libaio-0.3.109-13.el7.i686                                                                                                                               22/50

  Verifying  : libX11-1.6.7-2.el7.i686                                                                                                                                  23/50

  Verifying  : libX11-1.6.7-2.el7.x86_64                                                                                                                                24/50

  Verifying  : libXxf86misc-1.0.3-7.1.el7.x86_64                                                                                                                        25/50

  Verifying  : psmisc-22.20-16.el7.x86_64                                                                                                                               26/50

  Verifying  : libX11-common-1.6.7-2.el7.noarch                                                                                                                         27/50

  Verifying  : libXtst-1.2.3-1.el7.i686                                                                                                                                 28/50

  Verifying  : libxcb-1.13-1.el7.x86_64                                                                                                                                 29/50

  Verifying  : glibc-headers-2.17-292.0.1.el7.x86_64                                                                                                                    30/50

  Verifying  : nss-softokn-freebl-3.44.0-5.0.1.el7.i686                                                                                                                 31/50

  Verifying  : compat-libcap1-1.10-7.el7.x86_64                                                                                                                         32/50

  Verifying  : glibc-devel-2.17-292.0.1.el7.i686                                                                                                                        33/50

  Verifying  : libaio-devel-0.3.109-13.el7.x86_64                                                                                                                       34/50

  Verifying  : libmpc-1.0.1-3.el7.x86_64                                                                                                                                35/50

  Verifying  : 1:xorg-x11-xauth-1.0.9-1.el7.x86_64                                                                                                                      36/50

  Verifying  : glibc-2.17-292.0.1.el7.i686                                                                                                                              37/50

  Verifying  : ksh-20120801-139.0.1.el7.x86_64                                                                                                                          38/50

  Verifying  : gcc-c++-4.8.5-39.0.1.el7.x86_64                                                                                                                          39/50

  Verifying  : libstdc++-4.8.5-39.0.1.el7.i686                                                                                                                          40/50

  Verifying  : libSM-1.2.2-2.el7.x86_64                                                                                                                                 41/50

  Verifying  : libXxf86dga-1.1.4-2.1.el7.x86_64                                                                                                                         42/50

  Verifying  : mpfr-3.1.1-4.el7.x86_64                                                                                                                                  43/50

  Verifying  : compat-libstdc++-33-3.2.3-72.el7.x86_64                                                                                                                  44/50

  Verifying  : gcc-4.8.5-39.0.1.el7.x86_64                                                                                                                              45/50

  Verifying  : libXau-1.0.8-2.1.el7.x86_64                                                                                                                              46/50

  Verifying  : libXrandr-1.5.1-2.el7.x86_64                                                                                                                             47/50

  Verifying  : libgcc-4.8.5-39.0.1.el7.i686                                                                                                                             48/50

  Verifying  : kernel-headers-3.10.0-1062.1.2.el7.x86_64                                                                                                                49/50

  Verifying  : libXmu-1.1.2-2.el7.x86_64                                                                                                                                50/50

Installed:

  compat-libcap1.x86_64 0:1.10-7.el7  compat-libstdc++-33.x86_64 0:3.2.3-72.el7  gcc.x86_64 0:4.8.5-39.0.1.el7              gcc-c++.x86_64 0:4.8.5-39.0.1.el7                 

  glibc.i686 0:2.17-292.0.1.el7       glibc-devel.i686 0:2.17-292.0.1.el7        glibc-devel.x86_64 0:2.17-292.0.1.el7      ksh.x86_64 0:20120801-139.0.1.el7                 

  libXi.i686 0:1.7.9-1.el7            libXi.x86_64 0:1.7.9-1.el7                 libXtst.i686 0:1.2.3-1.el7                 libXtst.x86_64 0:1.2.3-1.el7                      

  libaio.i686 0:0.3.109-13.el7        libaio-devel.i686 0:0.3.109-13.el7         libaio-devel.x86_64 0:0.3.109-13.el7       libgcc.i686 0:4.8.5-39.0.1.el7                    

  libstdc++.i686 0:4.8.5-39.0.1.el7   libstdc++-devel.i686 0:4.8.5-39.0.1.el7    libstdc++-devel.x86_64 0:4.8.5-39.0.1.el7  oracle-database-preinstall-19c.x86_64 0:1.0-1.el7

Dependency Installed:

  cpp.x86_64 0:4.8.5-39.0.1.el7          glibc-headers.x86_64 0:2.17-292.0.1.el7     kernel-headers.x86_64 0:3.10.0-1062.1.2.el7     libICE.x86_64 0:1.0.9-9.el7            

  libSM.x86_64 0:1.2.2-2.el7             libX11.i686 0:1.6.7-2.el7                   libX11.x86_64 0:1.6.7-2.el7                     libX11-common.noarch 0:1.6.7-2.el7     

  libXau.i686 0:1.0.8-2.1.el7            libXau.x86_64 0:1.0.8-2.1.el7               libXext.i686 0:1.3.3-3.el7                      libXext.x86_64 0:1.3.3-3.el7           

  libXinerama.x86_64 0:1.1.3-2.1.el7     libXmu.x86_64 0:1.1.2-2.el7                 libXrandr.x86_64 0:1.5.1-2.el7                  libXrender.x86_64 0:0.9.10-1.el7       

  libXt.x86_64 0:1.1.5-3.el7             libXv.x86_64 0:1.0.11-1.el7                 libXxf86dga.x86_64 0:1.1.4-2.1.el7              libXxf86misc.x86_64 0:1.0.3-7.1.el7    

  libXxf86vm.x86_64 0:1.1.4-1.el7        libdmx.x86_64 0:1.1.3-3.el7                 libmpc.x86_64 0:1.0.1-3.el7                     libxcb.i686 0:1.13-1.el7               

  libxcb.x86_64 0:1.13-1.el7             mpfr.x86_64 0:3.1.1-4.el7                   nss-softokn-freebl.i686 0:3.44.0-5.0.1.el7      psmisc.x86_64 0:22.20-16.el7           

  xorg-x11-utils.x86_64 0:7.5-23.el7     xorg-x11-xauth.x86_64 1:1.0.9-1.el7        

Complete!

Loaded plugins: langpacks, ulninfo

Cleaning repos: ol7_UEKR5 ol7_addons ol7_developer ol7_developer_EPEL ol7_ksplice ol7_latest ol7_oci_included ol7_optional_latest ol7_software_collections

Creating Directory

Setting ENV

Downloading oracle database zip

Extracting oracle database zip

setting up Response files

Installing Oracle Binaries

Launching Oracle Database Setup Wizard...

The response file for this session can be found at:

/u01/app/oracle/product/19.0.0/dbhome_1/install/response/db_2019-10-06_11-16-39PM.rsp

You can find the log of this install session at:

/tmp/InstallActions2019-10-06_11-16-39PM/installActions2019-10-06_11-16-39PM.log

As a root user, execute the following script(s):

1. /u01/app/oraInventory/orainstRoot.sh

2. /u01/app/oracle/product/19.0.0/dbhome_1/root.sh

Execute /u01/app/oraInventory/orainstRoot.sh on the following nodes:

[git19c]

Execute /u01/app/oracle/product/19.0.0/dbhome_1/root.sh on the following nodes:

[git19c]

Successfully Setup Software.

Moved the install session logs to:

/u01/app/oraInventory/logs/InstallActions2019-10-06_11-16-39PM

Done

Last login: Sun Oct  6 23:16:39 GMT 2019 on pts/0

uid=54321(oracle) gid=54321(oinstall) groups=54321(oinstall),54322(dba),54323(oper),54324(backupdba),54325(dgdba),54326(kmdba),54330(racdba) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

SQL*Plus: Release 19.0.0.0.0 - Production

Version 19.3.0.0.0

Default 19c database install with PDB

Prepare for db operation

8% complete

Copying database files

31% complete

Creating and starting Oracle instance

32% complete

36% complete

40% complete

43% complete

46% complete

Completing Database Creation

51% complete

53% complete

54% complete

Creating Pluggable Databases

58% complete

77% complete

Executing Post Configuration Actions

100% complete

Database creation complete. For details check the logfiles at:

/u01/app/oracle/cfgtoollogs/dbca/ORCL19.

Database Information:

Global Database Name:ORCL19

System Identifier(SID):ORCL19

Look at the log file "/u01/app/oracle/cfgtoollogs/dbca/ORCL19/ORCL19.log" for further details.

Starting default listener

Parsing command line arguments:

    Parameter "silent" = true

    Parameter "responsefile" = /u01/app/oracle/product/19.0.0/dbhome_1/netca.rsp

Done parsing command line arguments.

Oracle Net Services Configuration:

Configuring Listener:LISTENER_ORCL19

Listener configuration complete.

Oracle Net Listener Startup:

    Running Listener Control:

      /u01/app/oracle/product/19.0.0/dbhome_1/bin/lsnrctl start LISTENER_ORCL19

    Listener Control complete.

    Listener started successfully.

Profile configuration complete.

Oracle Net Services configuration successful. The exit code is 0

Configuring the TNS

Testing Database

Last login: Sun Oct  6 23:33:31 GMT 2019 on pts/0

SQL*Plus: Release 19.0.0.0.0 - Production on Sun Oct 6 23:33:33 2019

Version 19.3.0.0.0

Copyright (c) 1982, 2019, Oracle.  All rights reserved.

Connected to:

Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

Version 19.3.0.0.0

SQL>

System altered.

SQL>

NAME   OPEN_MODE

--------- --------------------

ORCL19   READ WRITE

SQL>

    CON_ID CON_NAME   OPEN MODE  RESTRICTED

---------- ------------------------------ ---------- ----------

2 PDB$SEED  READ ONLY  NO

3 PDB19C  READ WRITE NO

SQL> Disconnected from Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production

Version 19.3.0.0.0

Cleaning up

DataBase Installed!!!

Database Name: ORCL19 with one pluggable database PDB19C has default password Welcome_1. Just switch to oracle user and login to database.